Minimum requirements for Outlook add-in to work.

  1. Exchange 2013, Exchange 2016, Outlook.com or Office 365 accounts only
  2. Mailbox requirement is 1.1 for the add-in to work, details are here https://dev.office.com/reference/add-ins/outlook/tutorial-api-requirement-sets
  3. IE 11 should be installed


Things to know

  1. Outlook web add-ins cannot be installed via an executable, this is now allowed by Microsoft, SCCM cannot be used.
  2. Outlook compatibility matrix 
Did this answer your question?